This website requires JavaScript.

Download

Get the latest OBSBOT software and firmware

Obsbot Studio APP

Requires iOS 9.0 or higher / Requires Android 6.0 or higher
Updated on 8/6/2019

OBSBOT Tail Firmware

Updated on 8/10/2019

Download